PDA

Просмотр полной версии : FMS порты (у заказчика не коннектится к серверу)


djyamato
21.03.2012, 12:46
Здравствуйте
вот этот плеер http://83.149.241.81/chto/chtoPlayerTest/CHTOPlayer.html
Играет потоки фмс (VOD)
Но у заказчика ни одного события NetStatusEvent.NET_STATUS не происходит
У него в логе последняя строка FMS connecting to rtmp://83.149.241.81/vod и все
У меня 2 вопроса:
1) что еще послушать чтобы понять причину
2) подозреваю что у него закрыты порты так как вот по этой ссылке (http://www.therealtimeweb.com/index.cfm/2004/10/2/fms-port-tester?CFID=851950&CFTOKEN=18716924) тестирование у него выдало вот что

RTMP DEFAULT Success
RTMP 80 Failed
RTMP 443 Success
RTMP 1935 Failed
RTMPT DEFAULT Success
RTMPT 80 Success
RTMPT 443 Success
RTMPT 1935 Success

Как фмс-у сказать чтобы он транслировал не на 1935 и 80 порты, а какие-нибудь другие ?
P.S. В fms.ini дописали ADAPTOR.HOSTPORT = :1935,80 добавив туда еще порт 443 - все равно у заказчика не показывает