Форум Flasher.ru
Ближайшие курсы в Школе RealTime
Список интенсивных курсов: [см.]  
  
Специальные предложения: [см.]  
  
 
Регистрация Блоги Правила Справка Пользователи Календарь Поиск рулит! Сообщения за день Все разделы прочитаны
 

Вернуться   Форум Flasher.ru > Flash > ActionScript 3.0

Версия для печати  Отправить по электронной почте    « Предыдущая тема | Следующая тема »  
Опции темы Опции просмотра
 
Создать новую тему Ответ
Старый 10.10.2017, 15:59
Appleman вне форума Посмотреть профиль Отправить личное сообщение для Appleman Найти все сообщения от Appleman
  № 1  
Ответить с цитированием
Appleman
 
Аватар для Appleman

Регистрация: Dec 2014
Адрес: Санкт-Петербург
Сообщений: 436
По умолчанию Вопрос по AIR

Други!

Коллега wolsh в соседней теме обратил моё внимание на среду Adobe AIR. Действительно, это как раз то, что мне нужно.
Долго трахался с прикручиванием к FlashDevelop-у компилятора для air, но заставил-таки работать. Смутил только один момент - версия.

У меня был установлен компилятор Flex, который содержит и AIR 3.1. Именно с этим номером версии (прописав его везде куда можно), всё заработало. Но я обратил внимание, что, например, в свойствах проекта, в списке версий air уже чуть ли не 23 в ходу. А я выбираю 3.1. Не страшно, что такая старая версия эксплуатируется? Я, признаться, вообще с трудом понимаю, на что это влияет.

Спасибо.

Старый 10.10.2017, 16:57
illuzor вне форума Посмотреть профиль Отправить личное сообщение для illuzor Найти все сообщения от illuzor
  № 2  
Ответить с цитированием
illuzor
 
Аватар для illuzor

Регистрация: Dec 2010
Адрес: Ярославль
Сообщений: 1,255
Лучше использовать последнюю стабильную. 3.1 очень сильно устарела.
Посленюю версию всегда можно найти на сайте adobe.

Старый 10.10.2017, 18:48
Appleman вне форума Посмотреть профиль Отправить личное сообщение для Appleman Найти все сообщения от Appleman
  № 3  
Ответить с цитированием
Appleman
 
Аватар для Appleman

Регистрация: Dec 2014
Адрес: Санкт-Петербург
Сообщений: 436
Цитата:
Сообщение от illuzor Посмотреть сообщение
Лучше использовать последнюю стабильную.
Главное слово "последнюю" или главное слово "стабильную"?
И плюс не совсем понимаю, как так получается, что в последнюю на сегодня версию Flex SDK 4.6 по факту оказывается интегрирована "замшелая" AIR 3.1?

Старый 10.10.2017, 19:00
illuzor вне форума Посмотреть профиль Отправить личное сообщение для illuzor Найти все сообщения от illuzor
  № 4  
Ответить с цитированием
illuzor
 
Аватар для illuzor

Регистрация: Dec 2010
Адрес: Ярославль
Сообщений: 1,255
Цитата:
Главное слово "последнюю" или главное слово "стабильную"?
Стабильность важней, ибо багов в эйре всегда хватало.

Flex SDK 4.6 уже сто лет, как не последний. https://flex.apache.org/installer.html

Старый 10.10.2017, 23:49
Appleman вне форума Посмотреть профиль Отправить личное сообщение для Appleman Найти все сообщения от Appleman
  № 5  
Ответить с цитированием
Appleman
 
Аватар для Appleman

Регистрация: Dec 2014
Адрес: Санкт-Петербург
Сообщений: 436
А какую версию AIR-а порекомендуешь?

Старый 11.10.2017, 00:27
GBee вне форума Посмотреть профиль Отправить личное сообщение для GBee Найти все сообщения от GBee
  № 6  
Ответить с цитированием
GBee
 
Аватар для GBee

Регистрация: Jan 2009
Сообщений: 3,067
Записей в блоге: 3
Отправить сообщение для GBee с помощью Skype™
Последнюю ))
__________________
Чтобы доказать, что вы не робот, причините вред другому человеку.

Старый 11.10.2017, 13:54
caseyryan вне форума Посмотреть профиль Отправить личное сообщение для caseyryan Найти все сообщения от caseyryan
  № 7  
Ответить с цитированием
caseyryan
 
Аватар для caseyryan

Регистрация: Jun 2012
Адрес: Новосибирск
Сообщений: 6,642
Записей в блоге: 4
Последнюю стабильную)
__________________
Ко мне можно и нужно обращаться на ты)

Старый 12.10.2017, 17:10
Appleman вне форума Посмотреть профиль Отправить личное сообщение для Appleman Найти все сообщения от Appleman
  № 8  
Ответить с цитированием
Appleman
 
Аватар для Appleman

Регистрация: Dec 2014
Адрес: Санкт-Петербург
Сообщений: 436
Господа изволят издеваться

А если серьёзно, то какая-то адская фигня с последним AIR-ом началась. Скачал, поставил, работать с трудом, но заставил. Мой проект вылетел на этапе компиляции с примерно 160 ошибками. Причём большинство было связано с хранением данных в хэш-таблицах.

Создал с нуля маленький тестовый проект. С всего одним помимо main-а классом-хранителем. Вот его код:
Код AS3:
	public class KeeperClass 
	{
		public static const HINT:Object = {
			(Main.ID + Main.recordID as String): ["testHint1", "testHint2"]
		}
 
		public static function getHint(hintID:String):String
		{
			return(KeeperClass.HINT[hintID+1][0]);
		}
Собственно в main просто обращаемся к этому классу и получаем строчку для вывода на экран. При попытке компиляции получаю ошибки:

Error: An externally-visible definition with the name 'test.KeeperClass' was unexpectedly found.
Error: Duplicate class definition: KeeperClass.
Syntax error: '(' is not allowed here
Syntax error: Expected SCOPE_CLOSE but got ':'
Error: An externally-visible definition with the name 'test.getHint' was unexpectedly found.
Error: A conflict exists with definition KeeperClass in namespace public.
Error: The static attribute may be used only on definitions inside a class.

Это ещё не все но думаю, ситуация понятна. Откуда всё это? Что это за лажа?
Со старой версией равно как с flex-ом всё прекрасно работало. А теперь ошибок больше, чем строк кода.

Старый 12.10.2017, 19:30
Wolsh вне форума Посмотреть профиль Отправить личное сообщение для Wolsh Найти все сообщения от Wolsh
  № 9  
Ответить с цитированием
Wolsh
Нуб нубам
 
Аватар для Wolsh

модератор форума
Регистрация: Jan 2006
Адрес: Бердск, НСО
Сообщений: 6,439
По поводу скобок в объявлении ключа Обжекта не уверен, а вот return точно не принимает параметров в скобки, это не функция)))

Добавлено через 3 минуты
А это как?
hintID:String
HINT[hintID+1]
__________________
Reality.getBounds(this);

Старый 12.10.2017, 20:11
ZackMercury вне форума Посмотреть профиль Отправить личное сообщение для ZackMercury Найти все сообщения от ZackMercury
  № 10  
Ответить с цитированием
ZackMercury
 
Аватар для ZackMercury

блогер
Регистрация: Jul 2013
Адрес: Север
Сообщений: 1,918
Записей в блоге: 23
Отправить сообщение для ZackMercury с помощью ICQ Отправить сообщение для ZackMercury с помощью Skype™
Любое выражение имеет право быть обёрнутым в скобки, в чём проблема то?
Цитата:
hintID:String
HINT[hintID+1]
Тоже не проблема, это конкатенация строки и числа.
Ошибки говорят другое.
Код AS3:
(Main.ID + Main.recordID as String): ["testHint1", "testHint2"]
Я говорил, что в ASC2 эта конструкция не работает, только со старым AIR.
__________________
There is no thing in this world that is not simple.

Создать новую тему Ответ Часовой пояс GMT +4, время: 03:39.
Быстрый переход
  « Предыдущая тема | Следующая тема »  
Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.


 


Часовой пояс GMT +4, время: 03:39.


Copyright © 1999-2008 Flasher.ru. All rights reserved.
Работает на vBulletin®. Copyright ©2000 - 2020, Jelsoft Enterprises Ltd. Перевод: zCarot
Администрация сайта не несёт ответственности за любую предоставленную посетителями информацию. Подробнее см. Правила.